WPS and Sequencer Issue

Discussion in 'Firing Systems And Fusing Fireworks' started by WR3_Pyro, Oct 14, 2021.

  1. WR3_Pyro

    WR3_Pyro Supports UKFR

    I know.. another post, but I have been fettling with my new sequencers today but I have run into a major headache..

    Everytime I hit the cue for sequencer input (in step mode) the sequencer is then hitting 4 of its 12 cues, sometimes more! WPS is obviously sending to many trigger signals per cue, I have tried reducing the pulses to 1 on WPS to no improvement.. if anyone has any idea how I can solve it I’d be appreciative.. or are they just not compatible with WPS.

    If it’s the latter I will have to sell them on!

    And yeah I have tested them all with a 9v battery trigger input and it works as you would expect!
     
  2. which sequencers are these ?
    have you tried a 0.1sec pulse or thereabouts?
     
  3. WR3_Pyro

    WR3_Pyro Supports UKFR

    Rhinofire Step 13s, tried 0.1s pulse which is what I use as standard :/
     
  4. wilkins1kc

    wilkins1kc Pro Firer/Crew Supports UKFR

    Probably worth checking with Easypyro to see if they've heard of any issues. I've used Rhino triggered by other firing systems without any drama. I also remember Andrew told me the Rhinofire input was debounced for scenarios where it is used with a pushbutton.
     
  5. WR3_Pyro

    WR3_Pyro Supports UKFR

    Yeah I phoned Andrew this afternoon, who also told me about the debouncing circuitry etc, I was fairly certain it wasn’t the rhino playing up. He did suggest a hardware hack adding a capacitor and resistor across the input but I don’t really want extra variables to give me issues on the night.
     
    wilkins1kc likes this.
  6. Madfish

    Madfish Pro Firer/Crew Supports UKFR

    is your Rhino trigger cue shared with other cues on WPS? - what I mean by that is I understand WPS multiplexes - if for instance you have slat A cue 1, slat B cue 1, slat C cue 1 all firing at the same time point, it sends current pulses very rapidly to A1,B1,C1,A1,B1,C1,A1,B1,C1 etc
     
  7. WR3_Pyro

    WR3_Pyro Supports UKFR

    I have taken it off script and just hooked it up to A1 then hit 1 on the mote and it’s then hit 3/4 cues on the rhino - if that helps clarify @Madfish
     
    Madfish likes this.
  8. WR3_Pyro

    WR3_Pyro Supports UKFR

    Looks like I can’t solve this issue without Heath Robinson style input addition I.e capacitors and resistors, I’m all out of ideas - The WPS pulse is just too aggressive!
     
  9. K9Girl

    K9Girl Tinsel Town Sales Reduction Ambassador Supports UKFR

    @WR3_Pyro not sure this will help but I did a test with my Pro and a Kingdom sequencer, worked perfectly. Are you sure it’s a WPS issue?
    (Excuse the dog throw hair) :oops:

     
    Pyro Pete and AlanCee29 like this.
  10. Scale it back and test each item on there own. Video for us might help
     
  11. WR3_Pyro

    WR3_Pyro Supports UKFR

    Thanks for that K9 :) appreciated! Wondering if can you put the kingdom in step mode and step through each one of the kingdoms cues by hitting 1 on the mote?

    @Pete Wright I will sort a video out tomorrow and have one final fettle! :)
     
  12. K9Girl

    K9Girl Tinsel Town Sales Reduction Ambassador Supports UKFR

    I’ll try tomorrow but I doubt it will work as the script will show the cue has fired, and doesn’t that defeat the object of a sequencer? :confused:
     
  13. Not if he's using it to expand a system rather than sequence as such. Cue 1 could potentially become 13 separate cues
     
    K9Girl likes this.
  14. I’m just trying to understand the setup but

    RinoFire should have the trigger in from one of the WPS ideally the cue/port within your show.
     
  15. why cant you have the rhino programmed for your sequence, just waiting for an input to start it?

    ok maybe not how you initially intended but could be a workaround.

    maybe there is a fault on the rhino....have you tried just using a battery to see what happens?

    anyway to check the rhino for faults?
     
  16. WR3_Pyro

    WR3_Pyro Supports UKFR

    All,

    Here is a video, lowest pulse time set on WPS, if I raise it I hit more cues with one pulse. @dave smith @K9Girl @Pete Wright

    Same issue across 3 rhinos so can’t be Rhino.

    See what you think, yes I can use them with a preprogrammed sequence but can’t use them as @The Real Malta Pyro said, for whacking banks of mines/single shots :(
     

    Attached Files:

  17. strange,
    be good to know what the issue is.
     
  18. wilkins1kc

    wilkins1kc Pro Firer/Crew Supports UKFR

  19. did you try andrews suggestion of a cap and resistor across the input terminals?
     
  20. WR3_Pyro

    WR3_Pyro Supports UKFR

    Not tried the capacitor and resistor addition as I don’t have a 100uf to hand plus I’m not sure I want to add variables to when it comes to showtime, il always be wondering if it’s going to fire 1 or 2, just glad I did test if I had blindly just chucked them in the field expect 1 hit would hit 1 cue I would of blown all my mine fronts in a matter of seconds and the finale would of been lacklustre.